Consul helm chart change http port

Hi all,

I have a legacy where consul is deployed in docker. In docker, we use 8630 in place of 8500 as http port.

I would like to keep the same approach in openshift for consistency but, looking at the helm chart configuration and at the templates, I don’t think it is configurable cause 8500 is present in many places in the templates. Can you confirm?

If it is not possible via helm chart configuration, I am thinking to create an additional service. Is this the best option?

Thanks ahead

Hi, unfortunately this is hard-coded in a lot of places and not something we can make configurable.

Creating a service won’t work because services would route to all consul clients but we need to route to only a specific client.


  1. I’ve been trying different configurations. I am yet to fully test it but it looks like the config below does what I want. What do you think?
    enabled: true
    enabled: true
    type: ‘ExternalName’
    additionalSpec: |
    - name: http
    port: 8630
    protocol: TCP
    targetPort: 8500
    enabled: false

  2. I had to disable the ingress part and to create it separately on cli cause adding the ports under additionalSpec broke the ingress part. Any idea why?
    Without ports under additionalSpec, I before had:
    enabled: true
    - host:

If you only need to make calls to the Consul servers this will work. The additionalSpec broke because I think the ports are set in the template already.