Coulnd't install dmsnitch provider

Hi Hashicorp,

We’re upgrading from v0.12 to v0.13 and slowly we’ve been trying to update our modules one by one. Eventually we hit this issue of not being able to find dmsnitch provider:

Error: Failed to query available provider packages

Could not retrieve the list of available versions for provider -/dmsnitch:
provider registry registry.terraform.io does not have a provider named
registry.terraform.io/-/dmsnitch

under our module, we’ve defined the provider as per the provider registry site but still we encounter the above issue. Can you please assist us?
https://registry.terraform.io/providers/plukevdh/dmsnitch/latest

terraform {
required_providers {
dmsnitch = {
source = “plukevdh/dmsnitch”
version = “0.1.2”
}
}
required_version = “>= 0.13”
}