Customizing ui content path with consul helm does not work

Hi,

with consul 1.9 and consul-helm 0.27.0 it is no longer possible to customize the ui content path.

before it could be done through the server.extraConfig value e.g.

extraConfig: |
{"ui_content_path": "/consul"}

According to consul release notes this config was deprecated with consul 1.9 so now it needs to be done differently e.g.

extraConfig: |
  {
    "ui_config": {
      "content_path": "/consul"
    }
  }

the new approach does not work and the content path is still defaulting to /ui. Am I missing something or how else can the ui path be customized now?

Hi @nflaig - my apologies for my previous post on this, I misread what you’d been asking. I’ve since deleted it as it wasn’t much help.

In the meantime I did confirm this behaviour as a bug which appears to have been introduced in consul 1.9.0 (as you mentioned).
We’re tracking it here : ui: ui-content-path flag/config no longer works (1.9.0/.1) · Issue #9522 · hashicorp/consul · GitHub
And we’ve got a fix in the works which should hopefully make it into 1.9.2
My apologies for the earlier confusion, and thank you for reporting the issue!

2 Likes

Hi @kschoche1

thanks for the response and great to hear that the issue is already tracked :slightly_smiling_face:

I probably should have opened the issue right away on GitHub put I wasn’t sure if I missed something obvious so I went to the forum first

1 Like