Deploying kubernetes cluster in azure with kubelet_config sending unsupported properties with Linux NodePools

when creating the Azure kubernetes cluster - AKS - deploying kubernetes cluster in azure with kubelet_config block without setting the properties to cpu_cfs_quota_enabled, Terraform provider is basically just calling the AzureRM API to create a AKS with all the parameters provided, but “cpuCFSquota” is created with FALSE.
With that, the setup of CPU Limits for the pod will be not respected.
We have tested 3 scenarios during the AKS cluster deployment.
1- Using AZ CLI to create the AKS cluster and perform the tests ( Status = CPU Limits working)
2- Using Terraform template without (kubelet_config) pod_max_pid = 4096 ( Status = CPU Limits working)
3- Using Terraform template with (kubelet_config) pod_max_pid = 4096 ( Status = CPU Limits not working)

based on this documentation: - Quickstart: Create an Azure Kubernetes Service (AKS) cluster by using Terraform - Azure Kubernetes Service | Microsoft Learn then I added the settings for kubelet_config and deployed the stress pods. Please check the main.cf

default_node_pool {

name       = "agentpool"

vm_size    = "Standard_E4s_v5"

node_count = var.node_count

kubelet_config {

      pod_max_pid = 4096

    }

(note: pod_max_pid - (Optional) Specifies the maximum number of processes per pod. Changing this forces a new resource to be created. This will create also the cpuCFSquota = FALSE, that will generate the issue on kubelet not being able to manage the CPU limits on the POD’s.

But if the parameter is enforced on terraform to TRUE, then cre POD’s created will be repect the CPU limits on the setup of creation of containers.

  • cpu_cfs_quota_enabled = true

Question: this is expected or it’s something wrong.
On Azure the default for cpuCFSquota is TRUE, but using Terraform the setting are being changed to FALSE.