Error on `terraform plan` "was not found in the list of supported Azure Locations"

I am running terraform on version >=2.90

terraform {
 required_providers {
    azurerm = {
      source  = "hashicorp/azurerm"
      version = ">=2.90"

resource "azurerm_resource_group" "example" {
  name     = "resourceGroupExample"
  location = "westeurope"

resource "azurerm_frontdoor" "frontdoor" {
  name                                         = "frontdoor"
  resource_group_name              =
  enforce_backend_pools_certificate_name_check = true

It was working fine before and suddenly it didn’t. I am getting error

Error: "resourceGroupExample" was not found in the list of supported Azure Locations`


when running terraform plan

I updated it to v2.94 but still didn’t work.

I see that there is no location in frontdoor and documentations says it is set to global

Later I changed it to “=2.93.1” which worked.

1 Like

Same issue here! Did you end up solving with the newer version or are we stuck to v2.93.1?

I have not tried other version yet. I have the version v2.93.1 for now.

We’re using v2.94.0 and also experiencing this issue… Have you guys got this to work? Any updates from the Hashicorp team?


EDIT: upgrading to 2.98.0 fixes this –
terraform init -upgrade

1 Like