Firewalld blocking: Error enabling audit device Put "" EOF


I have a Docker image running version 1.13.0 (also happened with 1.12.2) and use the ‘host’ network_mode, this is to make use of the AWS Instance profile without any problems. initialisation goes fine, but when i want to enable audit I get an error.

Audit enable command (that fails):

vault audit enable file file_path=/vault/logs/audit.log mode="0640"

But I get an error:

"Error enabling audit device: Put "https://FQDN:8200/v1/sys/audit/file": EOF"

When I disable FirewallD on the node, it goes fine. I have executed:

firewall-cmd --zone=public --permanent --add-port=8200/tcp
firewall-cmd --zone=public --permanent --add-port=8201/tcp

But that isn’t helping me. Any idea what I am missing that i need to do in firewalld?

Sorry, bad knowledge about firewalld. I needed to execute:

firewall-cmd --reload

afterwards. Now it properly works fine.