Freebsd Nomad client "pot" task driver is not recognized

Im trying to make Nomad to work with pot in AWS Freebsd instances.
I have gone trough requirements for the instance here Drivers: pot | Nomad | HashiCorp Developer , downloaded GitHub - bsdpot/nomad-pot-driver: Nomad task driver for launching freebsd jails. , and have put it under /home/ec2-user/nomad-client/plugins/pot/ and then created such client1.hcl file

# Increase log verbosity
log_level = "DEBUG"
# Setup data dir
data_dir = "/tmp/client1"
name = "client1"
# Enable the client
client {
  enabled = true
  servers = [""]
# Modify our port to avoid a collision with server1
ports {
  http = 5656
plugin "pot" {

(i have tried to put as plugin_dir .../plugins/pot/ and .../plugins/pot/pot, no luck)
i ran nomad client using this command
nomad agent -client -data-dir /home/ec2-user/nomad-client/ -servers= -config=client1.hcl
and it seems that im able to connect to the server, but im getting those kind of errors:
[DEBUG] client.driver_mgr: initial driver fingerprint: driver=docker health=undetected description="Failed to connect to docker daemon" or [DEBUG] client.driver_mgr.docker: could not connect to docker daemon: driver=docker endpoint=unix:///var/run/docker.sock error="Get \"http://unix.sock/version\": dial unix /var/run/docker.sock: connect: no such file or directory" obviously im trying to use another task driver, but seems im missing some configuration somewhere.

The issue was i needed to build proper binary before using this task driver.
Command that i used env GOOS=freebsd GOARCH=amd64 go build worked for me.
Then placed generated file into the plugins, and nomad was able to locate it.