How to authorize myself to Consul?

Hello,
I have installed Consul in Kubernetes but token page says I am not authorized.


I tried to fix problem by following links but none of them about Kubernetes. Is there a way fix that problem like a workaround, patch or anything else?

Thanks & Regards

Hi, what are your Helm values.yaml?

Hello @lkysow thanks for your response but I figured it out. Thanks for your attention.

1 Like

Nice! For folks stumbling on this issue what should they do?

It looks like the best option is to use a normal database like Postgres or MySQL as backend. The administration of Consul adds extra complexity to the system, not practical in daily operations and the documentation is not enough.

@tirelibirefe I have installed a new setup on my minikube cluster but from the consul UI I am not able to access the access control things like Auth methods, roles and policies. Can you help me by telling how did you enable them on your side ?

Hello @magr90900
I am a newbie for HashiCorp products too.
…but I try help you if I can…
Maybe you should create your own topic top level and explain your existing environment and the problem you faced with.

Sure thanks @tirelibirefe