How to disable Vagrant warnings?

Hello wonderful people,

My Vagrant is configured to launch ec2 machines, along with AWS SSM support for SSH connection. Everything works great but Vagrant prints out a bunch of warnings during vagrant up stage, and I’d love to disable them.

Can you guys point me in the right direction to disable these three warnings?

==> default: Warning! The AWS provider doesn't support any of the Vagrant
==> default: high-level network configurations (``). They
==> default: will be silently ignored.
==> default: Warning! You're launching this instance into a VPC without an
==> default: elastic IP. Please verify you're properly connected to a VPN so
==> default: you can access this machine, otherwise Vagrant will not be able
==> default: to SSH into it.
==> default: Warning! Vagrant might not be able to SSH into the instance.
==> default: Please check your security groups settings.

note: I don’t want to send vagrant up output to /dev/null to make it completely silent. I just want to disable these those warnings

I’m not sure you can “disable” them per se, but you can set the log level to the highest via the VAGRANT_LOG env var.

i.e. export VAGRANT_LOG=error

1 Like

Thanks for your response @Neutrollized

I wish I could set something in my vagrant config to disable these three warnings only. :anguished: