Performance.grpc_keepalive_timeout is invalid configuration?

I am using “consul:1.15.4” docker image and i added this configuration.

{
  "performance": {
    "raft_multiplier": 1,
    "leave_drain_time": "6s",
    "rpc_hold_timeout": "6s",
    "grpc_keepalive_timeout": "10s"
  }
}

and then i got this error

consul-server-p12 exited with code 1
consul-server-p12  | ==> failed to parse /consul/config/server.json: 1 error occurred:
consul-server-p12  |     * invalid config key performance.grpc_keepalive_timeout
consul-server-p12  |

acutally, i don’t need leave_drain_time, rpc_hold_timeout this config. I added for test, those are valid, but grpc_keepalive_timeout, grpc_keepalive_interval are invalid.

Hi @joomn11,

These parameters were added in Consul 1.15.7.

  • connect: Fix bug where uncleanly closed xDS connections would influence connection balancing for too long and prevent envoy instances from starting. Two new configuration fields
    performance.grpc_keepalive_timeout and performance.grpc_keepalive_interval now exist to allow for configuration on how often these dead connections will be cleaned up. [GH-19339]

You will need to upgrade to that minor release in order to configure those settings.

oh, thank you for answering
i am using dockerhub
when i check dockerhub(Docker)
version 1.15.4 is latest
is there some way, i can get 1.15.7 version of consul docker image?

Hi @joomn11,

That repo has this note on the overview page.

Upcoming in Consul 1.16, we will stop publishing official Dockerhub images and publish only our Verified Publisher images. Users of Docker images should pull from hashicorp/consul instead of consul. Verified Publisher images can be found at https://hub.docker.com/r/hashicorp/consul.

Running docker pull hashicorp/consul:1.15.7 will get you an updated image with these changes.

1 Like

This topic was automatically closed 62 days after the last reply. New replies are no longer allowed.