PKI engine issue certificate with "not_after" parameter is not working

I’m using Vault PKI engine to generate certificate.

And I’m using rest api to issue a certificate.
I wanted to set expire date with ‘not_after’ parameter but when I check the issued certificate, it still set the expire date with default ttl.

but it was working with “ttl” parameter. When I used ‘ttl’ parameter, it changed expire date of the certificate. But using ‘not_after’ didn’t change the default expire date even though I used correct UTC format.
I want to use expire date specifically with ‘not_after’ instead of ttl.