Terraform confluence escape backslash in URL address

Hello Dear All,

Any ideas how to escape “/” in URL to do not convert it in “%2F”?

Thank you

Hi @marian.sula,

You are using a community provider that I’m not familiar with here and this error seems to be coming from that provider, so I will try my best to help you start debugging this but if what I can answer isn’t enough you may need to ask this question in a different place specific to that provider, since I cannot be sure that anyone who works on that provider is active in this forum.

I’m guessing that this provider “confluence” is DrFaust92/confluence because its documentation shows the same set of arguments site, user, and token as you have in your example.

If so, the first thing I notice comparing the documentation with your example is that the documentation shows only a hostname in site, whereas you seem to have written a full URL in that argument.

Have you tried using only the hostname portion of that URL as the argument for site, rather than the whole URL? I guess from the documentation that the provider itself has a built-in rule for constructing the API base URL when given just the hostname portion, in which case you wouldn’t need to include the /confluence part.

If your confluence API base URL is not at the path the provider expects then unfortunately you may have to open a feature request with the provider developer for an additional argument to specify a path prefix to use, since the documentation for the provider doesn’t currently describe any way to deal with that situation.


Thank you for answer. Of course I tried it without “/confluence” prefix. But our API is beside that prefix (tried it using CURL method and in browser and “/confluence” is required).

Without this I am getting “404 not found”.