Terraform New Relic Provider Resource Not Found

I have a resource not found error coming up in my terraform when I run the new relic provider. I don’t have issues when I run the same code in a different new relic account. This is the provider configuration I am using:
terraform {

Require Terraform version 1.0 (recommended)

required_version = “~> 1.0”

Require the latest 2.x version of the New Relic provider

required_providers {
newrelic = {
source = “newrelic/newrelic”
version = “~> 2.48”

Hi @antonia.stove!

Since this is not an official provider maintained by staff at HashiCorp I cannot be sure that anyone in the forum here will be familiar enough with this provider to help, but perhaps someone from the community will be familiar with this and share what they know.

If not though, I might suggest contacting the team which maintains the provider (using whatever channels they suggest in the readme in the provider repository) and hopefully they will be able to tell you what this error message represents. I’m sorry I don’t have a more direct answer!