vSphere - namespace 'urn:pbm' are not supported

Terraform plan fails.

Error message: namespace ‘urn:pbm’ are not supported

vSphere (with license) version: 5.5.0
Terraform version: 0.12.20.
Ubuntu 16.04.5 LTS

I was used 0.11.13 - it was running properly for a long time, after that it broken,
I decided to upgrade to 0.12.20 which I thought will solve this, but apparently it didn’t.
When I run it on windows 10 (via a pycharm and a Python terraform client) I have no issues (same terraform version).

Help please )

I am also getting the same error…when do terraform plan
Error: ServerFaultCode: Request version ‘urn:pbm/’ and namespace ‘urn:pbm’ are not supported

on main.tf line 2, in provider “vsphere”:
2: provider “vsphere” {

yes, same configuration code as mine.

my vSphere Terraform plugin was incompatible with my vSphere version. I’v deleted the current vSphere plugin from Terraform configuration, then added the correct version of vSphere in main.tf and init Terraform. that created a new configuration vSphere plugin and solve the issue.

provider “vsphere” {
version = “1.12.0”