Aws_vpc_dhcp_options domain name "service.consul" causes issues for host names

I’ve had some success in getting Consul to work with Vault in AWS
but I’m having trouble configuring consul aws_vpc_dhcp_options in AWS such that the localhost name is correct.

The documentation example here seems strange:

in my case:

resource "aws_vpc_dhcp_options" "main" {
  domain_name          = "service.consul"
  domain_name_servers  = ["", "AmazonProvidedDNS"]
  ntp_servers          = [""]
  netbios_name_servers = [""]
  netbios_node_type    = 2

It’s strange because this seems to cause all hosts on boot to append ‘service.consul’ to their hostname. Whilst it does help to configure the search field in resolve.conf, it is causing issues for me since this isn’t correct on a centos host:

[centos@ip-10-4-102-19 dnsmasq.d]$ hostname

service.consul is meant to be only for services, not all nodes, and since nodes don’t register that address to consul, it will not resolve:

[centos@ip-10-4-102-19 dnsmasq.d]$ dig ip-10-4-102-19.service.consul

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.3 <<>> ip-10-4-102-19.service.consul
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 46406
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;ip-10-4-102-19.service.consul.	IN	A

consul.			0	IN	SOA	ns.consul. hostmaster.consul. 1613177477 3600 600 86400 0

;; Query time: 1 msec
;; WHEN: Sat Feb 13 00:51:17 UTC 2021
;; MSG SIZE  rcvd: 108

Apart from this consul is working for me with ubuntu and centos nodes but does anyone have ideas on how I should change the way I am configuring this to produce valid hostnames that will resolve?