Basic build error

I’m getting basic build errors when trying to setup my build environment.

==> Building...
+ gox -osarch=linux/amd64 -gcflags '' -ldflags '-X'\''1d0008dc79cf437c2da481f3dfb72fd43ee2df41+CHANGES'\''' -output 'pkg/{{.OS}}_{{.Arch}}/vault' -tags=vault -gocmd=go .
Number of parallel builds: 11

-->     linux/amd64:

1 errors occurred:
--> linux/amd64 error: exit status 2
Stderr: #*store).purge: relocation target runtime.walltime not defined relocation target runtime.walltime not defined*bucket).take: relocation target runtime.walltime not defined

make: *** [Makefile:35: dev] Error 1

Tried re-cloning from scratch, as well as blowing away my whole GOPATH and starting fresh. Anyone got a clue for me?

I found this:

Which was a commit 25 days ago to fix this (yes I’m on 1.17)…

Any chance of getting this module bumped to v0.7.0 (instead of the v0.3.0 in the current code) to fix this?


Same here, using:

  • Ubuntu 20.04.3 LTS
  • go version devel go1.17-ef7be8869c Tue Aug 10 11:44:14 2021 -0400 linux/amd64
  • branch: dev.boringcrypto.go1.17

Any chance @sethvargo has looked at the issue?

I tried bumping the dependency to v0.7.0, but ran into issues with the rate limiting code.

Appears a context.Context needs to be involved.

Otherwise, using golang (via Google repo) and branch: dev.boringcrypto.go1.16 worked.

This has been fixed in 0.7.0. There are no changes to context.Context in the limiter library from the previous version.

There seem to be some other changes though. Using latest vault with v0.7.0 produces the following errors for me:

[unit-test:201] .drone-cache/go/pkg/mod/ not enough arguments in call to
[unit-test:202]         have (string)
[unit-test:203]         want (context.Context, string)
[unit-test:204] .drone-cache/go/pkg/mod/ not enough arguments in call to
[unit-test:205]         have ()
[unit-test:206]         want (context.Context)