Boundary - Unable to connect to postgres target

Hi everyone I have set up a boundary cluster in hashicorp cloud and a postgres server on an ec2 instance. Port 5432 is exposed on the postgres server. I am able to authenticate to the boundary cluster and have set everything up but whenever I connect to my target I get this error:

error reading handshake result: failed to read protobuf message: failed to get reader: received close frame: status = StatusInternalError and reason = "refusing to activate session"

Any idea what is causing this? I am getting this same error on both linux and mac clients and the user I am using has an administrator role.

Hi @shimster102 a similar issue was reported internally and we are currently looking into it. I will update this post once we make progress in our investigation. Thanks!

Hey there @shimster102 - can you verify that this is still an issue for you? If it is can you:

  • Include the complete command you ran to connect to the DB
  • Verify that the ec2 instance running PG is publicly accessible

Thank you!

Oh I got this to work. As soon as I integrated vault to my boundary cluster it worked. I initially tried not to take the vault route.

I’m not sure what version of Boundary you are using but generally this indicates an issue with the client. A common example would be if you got a session authorization and then tried to use it from two different instances of boundary connect – this is prevented to prevent replay attacks, although we may introduce a feature to have similar capability in the future.

This shouldn’t have any impact from Vault or not; my guess is that you changed something else with respect to how you are using Boundary when you added the Vault integration.