Build Image Problem

I have a problem creating the script.

I am running a powershell script that is supposed to install QF-Test in silent mode.
The binary is copied accordingly in the provisioner and then the installation is started.

However, it seems that the installation never finishes. I don’t get any feedback from the packer either, so I don’t know what the problem is. The script works. I have tried it several times. The bottom line is that I do nothing other than

myexe.exe /VERYSILENT

If I execute this line in a shell, everything works perfectly… So I’m just going to be so bold and say that it’s the packer.

Other programmes can also be installed. But I must also say that QF-Test, with its 300 MB, is considerably larger than the other binaries.

Does anyone have any ideas what else I could do?

Does QF-Test require an interactive terminal? It may be trying to determine whether the terminal is interactive, or requesting privilege escalation. If this link is correct,

Please note that the installation for all users always requires elevated administrative rights. To also automatically accept the Windows UAC dialog the calling process must already have elevated rights. The parameter /CURRENTUSER does not help here, because the installation always requires elevated rights independent of installing for all or just the current user.
An exception of this rule is minisetup-noadmin.exe, which allows to configure an already installed QF-Test for the current user only. It does not need elevated rights.

it’s likely that the process is requesting privilege escalation during an interactive session, which packer can’t interact with

Instead of performing a silent installation you can also use the portable self-extracting archive QF-Test-6.0.4-sfx.exe.

Have you tried this?