Cannot get consul server instance running

I’m going through the Terraform deep dive on Plural Sights. I’m in module 4 and trying to get consul going. I’m running Windows 10 64 bit OS. In the training the command to issue is consul agent -bootstrap -config-file=“config/consul-config.hcl” -bind=“”, but that does not do anything. I have to run it like .\consul agent -bootstrap -config-file=“config/consul-config.hcl” -bind=“” and when it starts I get these errors below.
gent: Node info update blocked by ACLs: node=cc29147e-80f8-74c7-cf88-dc6871a5678c accessorID=00000000-0000-0000-0000-000000000002
agent: Coordinate update blocked by ACLs: accessorID=00000000-0000-0000-0000-000000000002

So you’re just saying you need an initial .\ prefix, then?

That’s entirely up to the installation methods followed, and choice of shell program used - it’s outside the control of Consul.

This is normal in a freshly bootstrapped cluster until you have created an agent ACL token to define what access level the built in agent functionality has to cluster state, and provided it to the agent.

Can you share the contents of config/consul-config.hcl? That will help us debug the root issue.

Like @maxb mentioned, this is an ACLs issue. You can learn more by completing this tutorial or referring to these set of docs.

These are the contents below. All project files were download from Github for the deep dive course.


ui = true
server = true
bootstrap_expect = 1
datacenter = “dc1”
data_dir = “./data”

acl = {
enabled = true
default_policy = “deny”
enable_token_persistence = true

Well the thing is I can’t get to that point to generate a token. Based on the training commands from m4_commands.txt.
Download the consul executable from
Go into the consul subfolder in m4
cd …/m4/consul
Create a data subdirectory
mkdir data
Launch consul server instance
consul agent -bootstrap -config-file=“config/consul-config.hcl” -bind=“” (I get error that’s posted and it never runs and I’m stuck at this point.
Open a separate terminal window to run the rest of the commands
Make sure you are back in the m4/consul directory
Cd m4/consul
Generate the bootstrap token
consul acl bootstrap ( I get The term ‘consul’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or
if a path was included, verify that the path is correct and try again. because it’s not running I believe) Based on the training it was no particular configuration I needed to run this on my laptop. All was needed was a AWS account, a app like VS code, and I think that was it. I know when I did the introductory course, there was another issue in the training that was resolved here, where I couldn’t download the AWS VPC module in terraform. So not sure if I’m the only one that runs into maybe one issue on the training lol.

You haven’t provided any link to the course you are doing. That makes it significantly more difficult for people to help you!

You have not posted any error that would prevent Consul from starting.

I was following these commands below from the training.
Launch consul server instance
consul agent -bootstrap -config-file=“config/consul-config.hcl” -bind=“”
Open a separate terminal window to run the rest of the commands
Make sure you are back in the m4/consul directory
cd m4/consul
Generate the bootstrap token
consul acl bootstrap

I retraced my steps and tried again this morning and it worked. it might have needed the .\ in front of consul acl bootstrap command. Thanks to everyone on your feedback. I’m still new to Terraform, and hoping to get more in depth.

Thanks again for your help. I guess it threw me off following along with the course. The one I’m doing is Terraform deep dive by Ned Bellavance. As I mentioned I had a issue in the first course, that someone on here help me resolve. I’ll give him feedback so anyone else taking the course will no this is normal behavior. In the training video, it never was mentioned and never had anything like that so I thought I was facing an issue.