Can't load package

Hi,
I’m installing Nomad and when I’m doing “make bootstrap” the output is:

==> Updating build dependencies…
go install github.com/hashicorp/go-bindata/go-bindata@bf7910af899725e4938903fb32048c7c0b15f12e
can’t load package: package github.com/hashicorp/go-bindata/go-bindata@bf7910af899725e4938903fb32048c7c0b15f12e: cannot find package “github.com/hashicorp/go-bindata/go-bindata@bf7910af899725e4938903fb32048c7c0b15f12e

GNUmakefile:103: recipe for target ‘deps’ failed
make: *** [deps] Error 1

Indeed I follow the Github’s URL and it’s showing 404 page not found.
Is there any alternatives to place in the GNUmakefile which will work?

Thank you very much!

Hi @bisby91 :wave:

Which version of Go are you using? And do you happen to have any GOPROXY orGOPRIVATE environment variable set?

GItHub and Go modules interpret paths in different ways, that’s why you see a 404 if you try to access it directly.

1 Like

Hi lgfa29,
Thank you so much for your reply and sorry for the slow one.
My Go version:
go version go1.15.5 linux/amd64

Sorry if it doesn’t sound correct I’ve never used Go:
I placed in my ~./bashrc file first:
export GOPROXY=https://proxy.golang.org
it didn’t work,
then:
export GOPRIVATE=github.com/repoURL/private-repo

I also tried by the command line:

go env -w GOPRIVATE=github.com/repoURL/private-repo

and still the same output.

Thanks

Hi @bisby91,

Are you able to output the response when you run go env?

Thanks,
jrasell and the Nomad team

Yes, I do get an output with multiple env variables,
Although I’ve been researching and I think I don’t need the installation from source in the end.
Thank you very much!

1 Like