Can't use remote templates on private repo

Hello. I’m trying to create a remote template in my enterprise organization. After creating the template and pushing a tag, I run

❯ cdktf init --template="https://<org and repo path>/archive/refs/tags/<tag>.zip" --local

The result is the following error

Extracting zip file
Error: end of central directory record signature not found
    at /usr/local/lib/node_modules/cdktf-cli/bundle/bin/cmds/handlers.js:110:448419
    at /usr/local/lib/node_modules/cdktf-cli/bundle/bin/cmds/handlers.js:110:456137
    at /usr/local/lib/node_modules/cdktf-cli/bundle/bin/cmds/handlers.js:110:438097
    at FSReqCallback.wrapper [as oncomplete] (node:fs:682:5)

which I believe to be from the inabillity to pull the zip file from the repository.

Can I get some assistance with this? Supporting a workaround for this such as referencing a local path for the template would effectively solve this.

Extra info:
This is the line in cdktf where it makes the request to download the file

Additionally, when I run a wget locally, I get an html file asking me to login with my SSO provider
Lastly, this is where the update would need to be made to support a local file

Hi @Zman94 :wave:

Unfortunately, that is not supported right now.

Linking the issue you created in case anyone else stumbles upon this thread: Can't use remote template on private repo · Issue #3320 · hashicorp/terraform-cdk · GitHub

– Ansgar