Catalog_schema.go:271:28: internal compiler error: assertion failed

Hi all

Consul newbie here. The latest consul.git has local compilation errors due to assertion fail. Does this need a bug filing with and/or is there a local fix in Consul src code?


bash-4.4$ make
mkdir -p bin
CGO_ENABLED=0 go install -ldflags "-X -X " -tags “”

agent/consul/state/catalog_schema.go:271:28: internal compiler error: assertion failed

Please file a bug report including a short program that triggers the error.

make: *** [GNUmakefile:147: dev-build] Error 2
bash-4.4$ uname -a
Linux xyx 4.18.0-305.7.1.el8_4.x86_64 #1 SMP Mon Jun 14 17:25:42 EDT 2021 x86_64 x86_64 x86_64 GNU/Linux
bash-4.4$ git version
git version 2.27.0
bash-4.4$ go version
go version go1.18.4 linux/amd64
bash-4.4$ cat /etc/redhat-release
Red Hat Enterprise Linux release 8.5 (Ootpa)

I tried building with the Go that I already had installed - 1.18.2 - and it worked.
Then I upgraded to 1.18.4 - and it failed!

So it looks like this is a new problem that needs to be reported to the Go project