Config Disable to check updates

Hello Team, Can someone tell me how to disable for check-point api for updates
We have a cluster which cannot connect to outside K8s worker nodes.

We need consul to stop checking for updates, currently getting error below.

2022-10-12T12:10:56.103Z [ERROR] agent: Failed to check for updates: error=“Get “”: EOF”

Hi @kadursandy,

Welcome to HashiCorp Forums!

Consul has the option to disable the update check (disable_update_check), which unfortunately isn’t configurable via Consul-K8S.

With that said, you can use the extraConfig option for both Consul Client and Server to set this configuration option.

I hope this helps.