Consul k8s cluster is not getting created without tls after enabling the acl

I am trying to create cluster with only server and client in k8s with the latest helm chart (0.43.0) and this is my values file

>   acls:
>     manageSystemACLs: true
>   gossipEncryption:
>     autoGenerate: false
>   tls:
>     enabled: false

I am getting following error

Error: INSTALLATION FAILED: DaemonSet.apps “test-consul-client” is invalid: spec.template.spec.initContainers[0].volumeMounts[2].name: Not found: “consul-ca-cert”

Is it mandatory to have tls enabled to for acl to working ?

No - but it appears a bug in the chart was recently fixed: update client-daemonset to not include ca-cert volumeMount with tls disabled by kschoche · Pull Request #1194 · hashicorp/consul-k8s · GitHub