Data external resource cannot execute python

I am trying to call python script

data "external" "example" {
  program = ["python", "${path.module}/ ${aws_iam_access_key.ses_user_key_nonprd.secret} ${var.replica_region}"]
│ Platform: windows
│ Program: "python"
│ Error: exec: "python": executable file not found in %PATH%

but it cannot find python on %Path%.
I have set path to python in windows env variables and i can see it when i echo %Path%.

I tried with python3 , same error. i tried giving full path to python program.

data "external" "example" {
  program = ["C:\\Users\\...........\\AppData\\Local\\Microsoft\\WindowsApps\\python", "${path.module}/ ${aws_iam_access_key.ses_user_key_nonprd.secret} ${var.replica_region}"]

│ Platform: windows
│ Program: "C:\\Users\\......\\AppData\\Local\\Microsoft\\WindowsApps\\python"
│ Error: exec: "C:\\Users\\.....\\AppData\\Local\\Microsoft\\WindowsApps\\python": file does not exist

but even in cmd when i call it , python is opening
i tried also with path./python.exe same result.

What is wrong with my path ?

It seems like you’re encountering a problem with specifying the correct path to the Python executable in a Terraform configuration file. The error messages indicate that Terraform is either not able to find the Python executable in the system %PATH% or not recognizing the full path you provided.

. Verify Python Installation

  • Check Python Installation: Ensure Python is properly installed on your system. You can do this by running python --version or python3 --version in the Command Prompt.
  • Correct Python Path: It’s possible that the Python path you added to your environment variables is not correct. Verify the path where Python is installed. Typically, for a Windows installation, it should be something like C:\Python39 (or another version number).