deployment is failing and its expecting a change in security settings

We have deployed a repo related to kafka clusters, earlier it was working fine without issues but now deployment is failing and its expecting a change in security settings. Error: The request does not include any updates to the security setting of the cluster. Verify the request, then try again. We have tried couple of changes as mentioend in one of the Github discussion Link : Terraform provider version : 5.30 1. Tried by adding client_authentication to ignore_changes and it didn’t 2. work. 2. Tried by adding client_authentication[0].tls to ignore_changes and it didn’t work. 3. Tried by setting unauthenticated = false in client_authentication and this too didn’t work. 4. Upgraded AWS provider version to 5.50 from 5.30 5. Also tried by downgraded it to 5.28 and still same deployment error. 6. Tried by setting tls{certificate_authority_arns=} Above al cahnges gave same error. We are not sure if this has something to do with AWS or Terraform but any help on this would be really helpfull. Note: As a temperory fix we had to make changes to security setting by enabling or desabling SASL/SCRAM authentication type for edhdev-cdc-kafka-cluster Cluster ARN: arn:aws:kafka:us-east-2:891422220700:cluster/edhdev-cdc-kafka-cluster/270e64c2-bab9-4a79-b020-5591b76855fb-7