EKS DNS Issues, after enabling `service_ipv4_cidr`

Hello, recently we found that our cluster does not correctly resolving dns configuration of aws eks cluster. So after we implemented:

   kubernetes_network_config         {
       service_ipv4_cidr             = ""

Inside of all pods we get wrong nameserver

/ # cat /etc/resolv.conf 
search default.svc.cluster.local svc.cluster.local cluster.local eu-central-1.compute.internal
options ndots:5 

At the end it should be but not

Is there any idea why it is impacting?

I came across your issue. In essence, you need to pass the same CIDR range into your kubelet. So when you launch a node you need to pass in –dns-cluster-ip “”.

Hope that helps.

You can read my fully story about this problem → Amazon EKS with custom service IPv4 CIDR | by Marcin Cuber | Oct, 2022 | Medium which provides more detailed solution when using Terraform or Karpenter.