Err="rpc error: code = Unavailable desc = transport is closing"

I am using terraform cloud enterprise
It errors out while making a plan

2021-04-02T04:04:38.570Z [WARN]  plugin.stdio: received EOF, stopping recv loop: err="rpc error: code = Unavailable desc = transport is closing"

Error: timeout while waiting for plugin to start

Terraform version: 0.14.7
aws provider version: 3.34.0

Hi,

Encountering same error. Did you ever solve it?

HI,

The error alone is unfortunately not enough to diagnose the issue, but it indicates that the plugin process, i.e. the provider, did not initialize before the timeout (which IIRC is 1 minute by default).

This is usually caused by some system limitation, most commonly insufficient CPU, memory , or an environment lacking a suitable source of randomness for generating the TLS keys.

Thanks for the input. Just solved the error, turned out to be what you mentioned: an azurerm provider error. An upgrade to latest version fixed it.

A post was split to a new topic: Remote-exec provisioner error