Error when provision read replica with binary log enabled

I used this module to provision my cloudsql Terraform Registry

  1. Provision master and read replica using terraform module above (version 5.7)
  2. Enable binary log on read replica using gcloud command
  3. But when running terraform apply, the error occurred :

│ Error: Error, failed to update instance settings for : googleapi: Error 400: Invalid request: Binary log must be disabled when backup is disabled or the instance must be a replica instance with a MySQL 5.7 or above version., invalid

│ with module.mysql.google_sql_database_instance.replicas[0],
│ on …/…/…/…/modules/google-cloud-sql/mysql/ line 39, in resource “google_sql_database_instance” “replicas”:
│ 39: resource “google_sql_database_instance” “replicas” {

this issue related to : Support google_sql_database_instance replica with settings.backup_configuration.binary_log_enabled=true · Issue #9371 · hashicorp/terraform-provider-google · GitHub

i tried using version 3.75.0 and latest version and error still on there.
also tried to create case support on GCP.

and this is he said :
I have been looking into this matter by attempting to reproduce the behavior you encounter, and I have been able to see the same error message you’re retrieving from executing your Terraform script.

Based on the verbose logs you provided, as well as the findings from the Cloud SQL Product Team, we were able to ascertain that the issue is present on Terraform, as it does not include the “instanceType” parameter which is required in order for the operation to succeed, as this can only be performed for instances of type “READ_REPLICA_INSTANCE”, or for instances with binary log disabled.

Given that this issue is caused by the Terraform provider making the API request, I suggest that you open an issue with the Terraform Team in their official GitHub repository 1 so that they may fix this issue in order to include the required “instanceType” parameter.

Alternatively, the Terraform team could switch from using the “PUT” method, which uses the instance.update method 2, to the “PATCH” method, which uses the instances.patch method 3. The latter automatically populates the fields that aren’t included within the request body, and should not cause the error message you’re encountering when the “instanceType” parameter is missing.