Error while bringin a multi machine vagrant file

I’m following examples from a book on how to setup ansible, in this case as a vagrant provisioner, it is my first contact with the tool and I had to customize the examples to use the libvirt provider that I already had configured on my machine.

When I tried to bring up the environment from this Vagrantfile.txt (895 Bytes) it presented all sorts of errors here is the log.txt (32.8 KB) the error massage told me to report it as a bug, but I am so unexperienced that I thought to look something up on my own, but the documentation available has been somewhat lackluster and most of the examples I could find where using VirtualBox, but I want the performance and flexibility of libvirt.

What did I do wrong? Thanks in advance for reading through, any help would be very much appreciated, especially on good resources for me to figure it out on my own.

Just for the sake of logging, running vagrant up a second time worked flawlessly, I’m at a loss… The first experience with the tool has been more downs than ups, let’s put it that way! :slight_smile: