Failed to query available provider packages for google provider

I have infra deployed through terraform in GCP and after nearly 6 months i am trying to deploy a new resource so i did terraform init but i am getting the bellow error

 Error: Failed to query available provider packages
  Could not retrieve the list of available versions for provider hashicorp/google: no available releases match the given constraints >= 4.0.0, >= 4.46.0, >= 4.74.0, >= 5.0.0, < 5.0.0, < 6.0.0

but i am able to download google-beta provider

terraform {
  required_version = ">= 0.15.0"
  required_providers {
    google = {
      source  = "hashicorp/google"
      version = ">= 4.0, < 5.0"
    google-beta = {
      source  = "hashicorp/google-beta"
      version = ">= 4.0, < 5.0"
    kubernetes = {
      source = "hashicorp/kubernetes"

Hi @pravin135!

The error message includes two conflicting constraints: >= 5.0.0, < 5.0.0.

There can be no version that is both greater than or equal to 5.0.0 and less than 5.0.0 at the same time.

This suggests that some other module in your configuration requires at least version 5.0.0 of the provider, which means that module is not compatible with the rest of your configuration that expects to be using only 4.x.x releases.

You can run terraform providers to get a summary of which modules depend on which versions of each provider. You’ll need to either change the modules to agree on at least one version of the provider that they are compatible with, or select different modules (or module versions) that have more agreeable provider version constraints.

Hi @apparentlymart
Thank you so much for your response…
As you can see i am using >= 4.0, < 5.0 and also I tried giving version= 4.64.0 that is previously used then also I am getting the error.