Failed to save raft snapshot

I am running Vault in a three-node cluster, using Raft as the integrated storage backend. Everything is working great except I am not able to save raft snapshots onto disk. It seems as if it fails to open file for writing.

Please take a look at the following snapshot:

ubuntu@ip:/tmp$ vault operator raft snapshot save /tmp/snap
Error taking the snapshot: Error making API request.

URL: GET http://localhost:8200/v1/sys/storage/raft/snapshot
Code: 500. Errors:

* 1 error occurred:
	* failed to create snapshot file: open /tmp/snapshot083311904: no such file or directory

While performing the above operation, I am logged in using root token.

Edit: I am also not able to save it from UI as well.

What user are you running vault under?
What permissions does that user have to /tmp?
What if you try the same command while in the user’s home dir (and just specify a filename)

Hey @mikegreen, thanks for your reply.
I am running Vault as ubuntu user. Ubuntu user has all the permissions (777) on /tmp. And, it doesn’t work while in the user’s home dir while specifying only filename.

Have you tried this from all 3 nodes with same result?
What if you use the actual Vault hostname/IP instead of localhost?
What if you run the command as sudo?
Which version are you using? It might be worth looking at the release notes for the version after to see if there was a bug fixed… There have been changes to the integrated storage backend substantially over 1.3-1.6.