Help with deploying secret plugin

I deployed the mock plugin (Build Your Own Plugins | Vault - HashiCorp Learn) with the Vault helm deployment; following what is mentioned in vault-helm/values.yaml at master · hashicorp/vault-helm · GitHub for plugins values (please see my helm override-values.yaml file below).
From inside the Vault pod I see the vault-plugin-secrets-mock indeed resides in the desired path (/usr/local/libexec/vault/vault-plugin-secrets-mock):

kubectl exec -it vault-0 – sh
/ $ ls -ltr /usr/local/libexec/vault/vault-plugin-secrets-mock
-rwxr-xr-x 1 vault vault 15735866 Jan 25 20:08 /usr/local/libexec/vault/vault-plugin-secrets-mock

However I get the following error when Vault starts:

==> Vault server started! Log data will stream in below:

2021-01-25T20:08:25.402Z [WARN] unknown plugin type: plugin name=vault-plugin-secrets-mock error="3 errors occurred:
* failed to load plugin as database v5: fork/exec /usr/local/libexec/vault/vault-plugin-secrets-mock: no such file or directory
* failed to load plugin as database v4: fork/exec /usr/local/libexec/vault/vault-plugin-secrets-mock: no such file or directory
* fork/exec /usr/local/libexec/vault/vault-plugin-secrets-mock: no such file or directory

I appreciate help Thanks.

server:
dev:
enabled: true
extraArgs: ‘-dev-plugin-dir=/usr/local/libexec/vault’
volumes:
- name: plugins
emptyDir: {}
volumeMounts:
- mountPath: /usr/local/libexec/vault
name: plugins
readOnly: true
extraInitContainers:
- name: mock-plugin
image: kind-registry:5000/plugin:latest
imagePullPolicy: Always
command: [/bin/sh, -ec]
args:
- cp /vault-plugin-secrets-mock /usr/local/libexec/vault/vault-plugin-secrets-mock
volumeMounts:
- name: plugins
mountPath: /usr/local/libexec/vault
readOnly: false