How can I override the 19000 port in envoy

I want to integrate consul and gloo together and for that I have two envoy and both runs on 19000 port. How can I override one of the envoy port

Hi @nishantthebridge,

If you are starting Envoy using the consul connect envoy command, you can specify an alternate port using the -admin-bind flag. For example:

$ consul connect envoy -sidecar-for=web -admin-bind=""

Consul does not support customizing Envoy’s admin bind address when running proxies on Kubernetes.

However, from it appears that Gloo allows you to provide a custom Envoy bootstrap config in which you can specify an alternate admin bind port. I recommend reaching out to the folks at Solo if you need a detailed example for using the gatewayProxies.$PROXY_NAME.configMap Helm values parameter.

Hi @blake

I see that the envoy admin port is hard coded as 19000 in configmap and to pass this as a parameter from values.yaml I will have to add the variable in configmap to override this and publish a new version of helm package. This is what I have done locally.

I have changed below in 9-gateway-proxy-configmap.yaml file -

port_value: {{ $spec.envoyPortValue }}

and I am passing this value from values.yaml as below -

envoyPortValue: 19010

If you find this solution well, I can contribute to your helm repo by raising a pull request to the helm Gloo repo.

Hi @nishantthebridge,

Gloo and its Helm chart are not supported by HashiCorp. I can’t comment on whether the folks at Solo would accept your modifications to their chart.

I suggest asking in Solo’s Slack org (, or filing an issue in the GitHub repo for the Helm chart so that they can provide this feedback.