How to configure nomad agent in DEV mode

I am trying to do some experiments with a local nomad install in dev mode.
As part of the test, I need to pull some docker images from a private AWS ECR registry.

I tried to replicate the setup described in this post:

… but, it seems that in dev mode, NOMAD is ignoring the agent settings in /etc.

What am I doing wrong?


Hi @matteo3849329,

What configuration are you passing the Nomad agent? When using the -dev flag you can also use other flags to modify the agent, including the -config flag.

jrasell and the Nomad team

thanks a lot jrasell, I somehow thought that nomad should have looked for config files in the default path - but using then -config parameter did the trick.