How to Limit :8500 to loopback

Hi, as Title says, can I limit the :8500 access to be localhost only? i cant with “client_addr”: “” since other services binds too on the loopback
Ps.: w/o using iptables

Hi @edgdelgado,

You can specify a different bind address for ports exposed by Consul under the addresses configuration option.

For example,

# DNS, gRPC, and HTTPS endpoints will bind to the first private IP
# address on the interface with a default route.
client_addr = "{{ GetPrivateIP }}"

# The HTTP endpoint will only listen on localhost.
addresses = {
  http = ""