How to toggle the flag "HTTP proxy integration"

I have custom templates for request and response, but it wont be applied unless i turn off the “HTTP proxy integration” flag. I cannot turn it off off via the console, i Need to do it via terraform.

this is all the docs offer: here

how would i go about to toggle this flag?