I just start with vagrant. I maintain the gitlab port for FreeBSD and use here vagrant to spin up a virtual machine to test the gitlab FreeBSD package.
The problem is now, that the disc for virtualbox is to small to allow a gitlab installation.
I searched and for vagrant there is a plugin available called
Regarding there installation I should execute:
vagrant plugin install vagrant-disksize
But I get this not clear error message:
vagrant plugin install vagrant-disksize ==> vagrant: A new version of Vagrant is available: 2.2.8 (installed version: 2.2.7)! ==> vagrant: To upgrade visit: https://www.vagrantup.com/downloads.html Installing the 'vagrant-disksize' plugin. This can take a few minutes... Vagrant failed to properly resolve required dependencies. These errors can commonly be caused by misconfigured plugin installations or transient network issues. The reported error is: Unable to resolve dependency: 'gitlab-puma_worker_killer (= 0.1.1.gitlab.1)' requires 'gitlab-puma (>= 2.7, < 5)'
There are hundreds of gems installed which are required for gitlab, but what has this to do with vagrant.
I also created a new FreeBSD package for this plugin, but the package does install the rubygem only to
/usr/local/lib/ruby/gems/2.6/gems/vagrant-disksize-0.1.3/ but I have no idea, how I can register this plugin with vagrant without getting this error message.
Could you please point me in the right direction to fix this problem or how I can register the plugin without getting the strange error message and not downloading anything but use the files locally available?
Thanks a lot.