IPV4 address is not identified when booting RHEL machine using packer

In my case i’m build a VM from RHEL 7.9 iso and while referring to ks.cfg file it says - not able to access URL which is http://xx.xx.xx.xx:8209/ks.cfg but i’m able to access through browser.
Is it because packer automatically searching of IPv6 address instead ipv4 ?
is there any option to include in Builder section to specify ‘use IPV4’ something like this.

What builder are you using?

Thank you for your response .
The problem was with my boot_command . Its fixed now.

Thank you