Issue creating TOTP for ldap

I am having issue enabling TOTP after authentication with LDAP
LDAP Login without TOTP works fine
I followed this guide without facing any errors
Active Directory Auth Method with TOTP Login MFA | Vault - HashiCorp Learn
However the TOTP does not work after login
The server does not show any errors when debugging is enabled

vault login -method=ldap username=user
Password (will be hidden):
Enter the passphrase for methodID "9b6bbfbb-9e62-db24-7d98-d105172283d4" of type "totp":
Error making API request.

Code: 403. Errors:

* failed to satisfy enforcement adtotp. error: 2 errors occurred:
        * failed to validate TOTP passcode
        * login MFA validation failed for methodID: [9b6bbfbb-9e62-db24-7d98-d105172283d4]
1 Like

I’m facing the same problem, I followed same guide but with userpass auth method and i’m getting the exact same error

Following MFA Login with Vault TOTP | docmoa
It only worked with SHA1 TOTP Algorithm

Can confirm that I’ve ran into the same issue and it only worked when I switched to SHA1 TOTP Algorithm

Same issue here. It only worked with SHA1 TOTP Algorithm

How to bind the totp key with the ldap entity