Issue with Vagrant

we have a user that when she try to do Vagrant up get an error

she was told to install rubyencoder but that doesn’t help
so she uninstall it and reboot we still have these 2 errors
anyone can help ?

nobody can help on this ?

The error from your screenshot says that they are using a 32 bit version of Vagrant. They should uninstall that package, and make sure they’ve installed the 64 bit version: Downloads | Vagrant by HashiCorp

Additionally, if it’s the case that they are on a 32 bit installation of Windows, that is no longer supported, as Vagrant only ships 64 bit packages.

hello again
well we uninstall the vagrant reboot reinstall the 64 bits reboot again and now we have this error : image-3


Hey @augerp - That looks to be a parse error from Vagrant parsing your Vagrantfile, which means it looks like you got past the initial issue so that’s great. Can you share that Vagrantfile specified at Path?

i can yes but i need to remove some info from the file

here you go Vagrantfile_mod.txt (3.7 KB)

Thanks @augerp

So the issue here is how the triggers are defined. With what you shared, you have triggers defined like:

	config.trigger.after [:up, :resume, :reload] do
		run "hostile set #{ip_address} #{domain_name}"

They should actually be defined like:

	config.trigger.after [:up, :resume, :reload] do |trigger| "hostile set #{ip_address} #{domain_name}"

Notice the trigger enumerator here. This is required for the run option to be defined and for vagrant to parse a trigger block. Hopefully that makes some sense!

we will try that and let you know if i need further help :slight_smile:

1 Like

well she test and told me there an error


@augerp Oops, sorry my mistake. The needs an = sign:

	config.trigger.after [:up, :resume, :reload] do |trigger| = "hostile set #{ip_address} #{domain_name}"

it seems its not changing anything she get this :

@augerp that looks to be the same error previously mentioned. I noticed you have a couple of trigger blocks so she’ll want to make sure to update each one with that |trigger| enumerator I mentioned, as well as update the run like to say =. If that doesn’t work, feel free to share the Vagrantfile again and we can see what could be missing.

hello we are going a bit further
now we have this :slight_smile:
Vagrant encountered an error while attempting to load the utilityservice key file. This error can occur if the Vagrant VMware Utility
has not yet been installed, or if it was installed incorrectly.

Thanks helping

Hrm @augerp - I suggest trying to remove the vagrant vmware utilitiy, and then re-install the vmware vagrant utility to make sure it was set up properly: Installation - VMware Provider | Vagrant by HashiCorp From the error it looks like it was just not installed right, so hopefully removing it and following the instructions will resolve the issue.

well after the reinstallation we have this : MicrosoftTeams-image (10)

@augerp You’ll need to use a different synced_folder option if you’re on Windows. As the message says, NFS isn’t supported on windows. The default option should be good enough if you are using the vmware provider. Looking at your Vagrantfile, you can probably just remove the synced_folder line in your config, as that folder syncs by default. But if you want to be safe, just remove the nfs: true and the mount_options from that config and it should use the default vmware synced folder.

now we have this :frowning: