Needed plugin not available

I am trying to execute following command
packer build ubunthu.json

Please suggest what exactly need to be installed and please provide respective links

Hi @sk8228402 thanks for reaching out, with the removal of bundled plugins from Packer 1.10.0 plugins previously shipped in the Packer binary must now be installed separately. Unfortunately, this is not something that can be codified in JSON templates, which is why you are seeing this issue.

Have you tried following the integrations link in the error message?

To get past this initial issue you want to run the following command to install the latest version for the Azure plugin.

packer plugins install

For external plugins such as Azure, you will find instructions on the integration portal for installing the plugin using the packer plugins install command for JSON users and packer init for HCL2 template users.

If you are working mainly with JSON templates then the packer plugins install will help you manage any external plugin required for your builds. If you are just getting started with Packer I recommend taking a look at HCL2 templates over JSON, as JSON templates are considered legacy at this time.

If you want to give HCL2 a try, you can convert your JSON template to HCL2 by running

packer hcl2_upgrade ubuntu.json

Hi Nywilken,

I have installed plugins, it worked. but I am seeing different error related to resource although resource group is available