New box hangs during start


I’m trying to package a new Vagrant box but I never manage to start it properly.

At first, I thought my box was broken, but I even have this issue when trying to package a vanilla Debian box.

I’m currently using Vagrant 2.2.14 from Debian Bullseye (11) and my process is as follows:

  1. In a newly created directory, I run vagrant init debian/buster64
  2. Without changing the default Vagrantfile, I run vagrant up. A Debian Buster box is started with the libvirt provider.
  3. I then run vagrant package --output
  4. When the box has been prepared, I add it with vagrant box add --name mytest
  5. In an other newly created directory, I now run vagrant init mytest and vagrant up.
  6. I get no error, but the process gets stuck forever at ==> default: Waiting for SSH to become available.... From virt-manager, it looks like the machine is running, but I can’t SSH into it.

Am I missing something in my process? My guess is that I made a trivial mistake, but I can’t figure what it is. :slightly_smiling_face:

Thanks a lot in advance for your help,