No compatible versions of provider were found

Using the latest Terraform v0.13 and Azure RM v.2.20.0, I receive the following error on ‘terraform init’. Something is looking for a provider called ‘azure’ instead of ‘azurerm’ . I am not sure where this information is coming from. Any ideas?

$ terraform init
Initializing modules...

Initializing the backend...

Initializing provider plugins...
- Using previously-installed hashicorp/template v2.1.2
- Using previously-installed hashicorp/external v1.2.0
- Using previously-installed hashicorp/azurerm v2.20.0
- Using previously-installed hashicorp/random v2.3.0
- Using previously-installed hashicorp/null v2.1.2
- Using previously-installed hashicorp/tls v2.2.0
- Using previously-installed hashicorp/local v1.4.0
- Finding latest version of terraform-providers/azure...

Error: Incompatible provider version

No compatible versions of provider were found.

Here’s the provider:

provider “azurerm” {
version = “~>2.20.0”
subscription_id = deadbeef-deadbeef-deadbeef"
features {}

And terraform --version:

$ terraform --version
Terraform v0.13.0

Perhaps you can share the content of your TF files? I’ve just installed v0.13 with a simple with the below content and receive no errors during terraform init. The init output shows:
* hashicorp/azurerm: version = "~> 2.24.0"

resource "azurerm_resource_group" "test" {
  name     = "my-resources"
  location = "West Europe"
$ terraform --version
Terraform v0.13.0
+ provider v2.24.0

Thanks. I’ll work on cutting my TF files down… Then share if I can still reproduce the issue

Problem was this file ( which was generated by an earlier terraform command:

terraform {
required_providers {
azure = {
source = “terraform-providers/azure”
azurerm = {
source = “hashicorp/azurerm”
random = {
source = “hashicorp/random”
required_version = “>= 0.13”

And to be fair, that was because I specified azure_ rather than azurerm_ in the terraform import command. I assume that’s where it came from, anyway