No handler for route error although I believe the secrets engine is enabled

hi everyone,

Using the non-dev vault server, I went ahead and used “Enable new engine” in the UI for kv version 1 and created a secret.

As a test, I am using a token with root permissions to attempt the following and receive the no route error:

curl -H "X-Vault-Token: " -X GET

{“errors”:[“no handler for route ‘secret/kvtest/anothertest/test’”]}

My understanding is that there shouldn’t be the no handler issue as I enabled that secrets engine through the UI. Am I missing a step, policy, or is this an API path issue?

Thank you,

One of my references was which lead me to review the enabled amount.

I’ve tried this for kv enabled secrets engine v1/v2 and still return {“errors”:[“no handler for route ‘secret/kvtest/anothertest/test’”]} via curl -H "X-Vault-Token: " -X GET

I am going to keep trying but otherwise I believe there could be a potential issue with the vault instance that I deployed.

What port are you running Vault on?
Should be
in most deployments.

1 Like

thank you! that helps as well. so, for anyone stuck on the same issue, it’s definitely a path issue, don’t panic like I did. I was under the very wrong assumption that there was some data corruption.

I ended up listing the existing mounts to verify the actual path.