Nomad 1.1.1 and "consul.connect = enabled" on consul clients

I am a bit confused about this point. The consul documentation states the following:

“The first step to use Connect is to enable Connect for your Consul cluster. By default, Connect is disabled. Enabling Connect requires changing the configuration of only your Consul servers (not client agents) . To enable Connect, add the following to a new or existing server configuration file.”

For Nomad 1.1.1 I now had to reconfigure all consul-clients with this setting in consul configuration, otherwise the Nomad connect-jobs got stopped/filtered by Nomad by “connect.enabled = true” missing.

I couldn’t find any reference in the consul-documentation stating this should be set on client nodes (hence I only set it on my servers). It was a bit confusing to me, or maybe I just missed it in the COnsul documentation?

Hi @kds-rune :wave:

That’s an interesting question. I wonder if Nomad is only looking at the local Consul agent to build this new constraint :thinking:

Would you mind opening an issue in our GitHub repo?

Thank you!

@kds-rune you’re absolutely correct - the additional constraint added in this recent change on checking for connect.enabled = true on Client agents is erroneous. The setting is only required to be set on Consul server agents. We’ll get a fix out for this soon.

1 Like