Nslookup fails on Windows docker host with consul running in container

Problem: When I run consul in a docker container on Windows, nslookup fails.

nslookup -port=8600 consul.service.consul
Server:  UnKnown

*** UnKnown can't find consul.service.consul: No response from server

However, if I run the same command from a debian container with host networking on the same docker host, it works fine. Example:

docker run -it --rm --net=host debian /bin/bash
apt-get update && apt-get install -y dnsutils
nslookup -port=8600 consul.service.consul

Name:   consul.service.consul

I’m a bit stumped as to why nslookup fails on the Windows docker host, but succeeds in a host networked container. I’m trying to figure out if this is an issue with my configuration, not running the correct command on Windows, docker on Windows shenanigans, etc. FWIW, I can access the UI on just fine.

Command I used to create the container:

docker run `
--name=consul-server `
-v "C:/Consul/Consul.d:/consul/config" `
-v "C:/Consul/Data_dir:/consul/data" `
-p 8300:8300 `
-p 8301:8301 `
-p 8302:8302 `
-p 8500:8500 `
-p 8501:8501 `
-p 8600:8600/tcp `
-p 8600:8600/udp `
consul:1.10.2 `
agent -server

My config:

	"data_dir":  "/consul/data",
	"client_addr": "",
	"bind_addr": "",
	"retry_join": [""],
	"datacenter": "ag-dev",
	"log_rotate_max_files": 29,
        "server": true,
        "bootstrap_expect": 1,
        "ui": true

To answer my own question, this is just a Windows thing with DNS and nslookup.