Podman rootless containers end up not having a loopback interface when using Nomad

Hope someone’s got an answer for this one; I have a podman rootless container that, when I run it locally, works just fine. There are a few things running inside that communicate with eachother over the loopback interface, and it runs systemd (feh…)

When I run it with Nomad’s podman driver, however, it stops working. The loopback interface is never brought up, and all the services inside the container are now not functional. Trying to bring up the interface at boot via script results in “SIOCSIFFLAGS: Operation not permitted”. And no joy.

How to make this work under Nomad?

Hi @benvanstaveren :wave:

Would you be able to provide a minimal reproduction? It’s kind of hard to understand what may be going wrong.


We’ve had some success with podman 4, the setup I tried it on had podman 3 on it, and it seems there’s some things that just “don’t work right” in that situation. We’ve got it pretty much nailed down to the point it’s something to do with the container or the way the podman driver starts it.

Unfortunately I can’t really give you a reproduction, there’s some proprietary shenanigans happening and I can’t break those out for a quick repro image :confused: