Port forwarding remote-exec

My environment the default port (22) of linux it’s blocked, so my script when start the command remote-exec shows an error of time out

how to make remote-exec command work on another port? Ex. port 4444

The connection block has a port argument to set the desired port.

1 Like

In addition to @jbardin’s answer, the documentation section Provisioners are a Last Resort suggests some other possible strategies which could allow you to avoid dealing with the complexity of setting up an SSH connection at all, by having all of the initialization work happen directly on the machine you’re launching.