Please refer below screenshot:
As per my providerding below terraform v1.2.6 indicates terraform version
and version 3.79.0 indicating provider version
is my above statement correct?
I have below 2 questions
2. what does require version(line number 3) indicates is it for provider or terraform?
3. we have already given >2.0 so what >=0.15 indicates?
The “required_version” is for terraform.
The “version” is for the azurerm provider.
Your first statement is correct. Regarding the other two questions…
The top configuration example declares that:
- This module requires at least Terraform CLI/Core v0.15.
- This module requires the provider plugin
hashicorp/azurerm, using the shorthand “azurerm” when referring to it elsewhere in this module, and that the module requires at least version 2.0 of that provider.
terraform version output below indicates that:
- You are running Terraform CLI/Core v1.2.6
terraform init has selected v3.79.0 of
hashicorp/azurerm, and recorded that selection in the dependency lock file. (The list of providers in
terraform version is really just a summary of the information in the dependency lock file, which is what Terraform CLI uses to find the selected providers.)